Blog ENI : Toute la veille numérique !
Accès illimité 24h/24 à tous nos livres & vidéos ! 
Découvrez la Bibliothèque Numérique ENI. Cliquez ici
Accès illimité 24h/24 à tous nos livres & vidéos ! 
Découvrez la Bibliothèque Numérique ENI. Cliquez ici
  1. Livres et vidéos
  2. Les réseaux
  3. Corrigé 4
Extrait - Les réseaux Administrez un réseau sous Windows ou sous Linux : Exercices et corrigés (7e édition)
Extraits du livre
Les réseaux Administrez un réseau sous Windows ou sous Linux : Exercices et corrigés (7e édition)
1 avis
Revenir à la page d'achat du livre

Corrigé 4

Prérequis

1.

Bus, étoile et anneau.

2.

La topologie physique décrit simplement la connectique, l’aspect visuel du réseau. La topologie logique est quant à elle plutôt fonctionnelle.

3.

c.

Un MAU ou Multistation Access Unit. Un connecteur BNC ou British Naval Connector était utilisé sur les cartes réseau en coaxial fin. Un connecteur DIX (Digital, Intel and Xerox) ou AUI (Access Unit Interface) est un connecteur DB15 qui était utilisé sur les cartes réseau reliées à un câble en coaxial épais.

4.

c.

Le connecteur DB9 est caractéristique d’une carte réseau Token Ring. Ce connecteur est en général associé à un connecteur RJ45. Les cartes Ethernet ne disposent pas de connecteur DB9, mais plutôt DIX, BNC, RJ45 ou ST. FDDI (Fiber Distributed Data Interface) s’appuie sur de la fibre optique exclusivement pour les communications. Ethernet et 802.3 sont sensiblement proches dans la forme des trames utilisées.

5.

Coaxial fin et épais (quasiment plus utilisé), fibre optique et paire torsadée.

6.

Le domaine de collision comporte exclusivement des composants de niveau 1.

7.

Un routeur est défini au niveau 3 OSI (couche réseau).

8.

b.

Le pont qui fonctionne au niveau 2 OSI va apprendre automatiquement les adresses MAC utilisées de part et d’autre....

Corrigé 4.1 Identification visuelle des topologies

a.

Étoile.

b.

Anneau.

c.

Bus.

d.

Bus en étoile.

e.

Maillée.

f.

Étoile hiérarchique ou arbre.

g.

Hybride.

Corrigé 4.2 Topologies et composants

a.

Commutateur de groupe de travail Ethernet. Topologie en étoile.

b.

Convertisseur RJ45/SFP Gigabit. Connexion point-à-point dans un contexte de bus en étoile.

c.

Multistation Access Unit Token Ring (ancienne génération avec prises hermaphrodites). Topologie logique en anneau et physique en étoile.

d.

Carte réseau PCI Express SFP+ 10 G Ethernet (LR=Long Reach, SR=Short Reach, LRM=Long Reach Multimode). Topologie en étoile (la carte réseau est connectée en point-à-point avec le commutateur).

e.

Carte réseau Ethernet. Topologie en étoile.

f.

Ancien câble coaxial fin Ethernet. Topologie en bus.

g.

Ancien transceiver (émetteur-récepteur) coaxial épais/coaxial fin. Topologie en bus.

h.

Ancienne carte réseau Token Ring. Topologie physique en étoile et logique en anneau.

Corrigé 4.3 Modes de communication

1.

a.

Câble coaxial fin utilisé sur les réseaux Ethernet (10base2). Le mode de communication est une émission/réception alternée avec un codage Manchester en bande de base (à une fréquence).

Half-duplex

 

b.

Câbles en fibre. La fibre multimode est utilisée en mode simplex ; c’est la raison pour laquelle deux fibres sont utilisées pour connecter deux composants réseau. Cependant, avec la fibre monomode, il est possible d’utiliser deux signaux opposés, de longueur d’onde distincte, autorisant ainsi un fonctionnement bidirectionnel sur une seule fibre monomode.

Simplex

 

c.

Câble coaxial épais. Utilisé sur les réseaux Ethernet 10base5. Il s’agit également d’une communication alternée avec un codage bande de base (Manchester).

Half-duplex

 

d.

Câble en paires torsadées. Ce type de support (le plus utilisé) a une capacité d’émission/réception simultanée grâce à ses 4 paires.

Full-duplex

2.

images/04TP51.png

Corrigé 4.4 Méthodes d’accès au support

1.

Voici le tableau que nous obtenons :

Type de méthode

Contention

Jeton passant

Polling

Type de couche réseau

Ethernet

LocalTalk

Token Ring

IEEE 802.5

FDDI

100VAnyLan

Type d’algorithme utilisé

CSMA/CD

CSMA/CA

Token Passing

DPAM

2.

images/04TP53.png

Corrigé 4.5 Domaines de bande passante et de diffusion

a.

Ici, il n’y a qu’un seul domaine de collision Ethernet qui est aussi le domaine de diffusion. 

images/04TP54.png

b.

Ici, nous utilisons un commutateur de niveau 2. Nous n’avons pas parlé de VLAN ici, par conséquent nous supposons qu’il n’y en a pas.

images/04TP55.png

Note

Notez néanmoins que ce modèle de commutateur (Cisco Catalyst 2950) prend en charge les VLAN.

c.

Les deux hubs font office de répéteurs (niveau 1) ; par conséquent, les domaines de bande passante et de diffusion ne font qu’un.

images/04TP56.PNG

d.

Le hub Ethernet et le MAU sont des équipements de niveau 1 OSI, les commutateurs des équipements de niveau 2 (ici la notion de VLAN n’a pas été indiquée) et le routeur, un équipement de niveau 3.

Trois domaines de diffusion se distinguent en partant du routeur.

images/P174A.png

 

Ensuite, les domaines de bande passante sont définis au niveau de chaque port de chaque commutateur.

D’après le schéma proposé, il y a ainsi trois connexions sur le premier commutateur, donc trois domaines de bande passante et cinq sur le suivant (en tenant compte du branchement du routeur sur le second commutateur). Le réseau Token Ring constitue, à lui seul, son propre réseau de bande passante qui est aussi le domaine de diffusion (pas de pont, ni de commutateur sur cette partie).

 

Finalement...

Corrigé 4.6 Composants d’interconnexion et modèle OSI

a.

Il s’agit d’un mini-hub 8 ports Ethernet pour petit réseau (groupe de travail). Ce composant agit au niveau 1 du modèle OSI. Il se comporte comme un répéteur.

b.

Il s’agit d’un répéteur permettant d’étendre la distance parcourue sur un câble coaxial fin (Ethernet 10base2) au-delà de 185 mètres. Ce composant agit au niveau 1 du modèle OSI.

c.

Il s’agit d’une carte réseau 3C589C au format PCMCIA pour portable. Cette carte, de type combo, autorise des connexions à des réseaux Ethernet 10baseT (paire torsadée) ou 10base2 (coaxial fin). Une carte réseau est définie sur les niveaux 1 et 2 du modèle OSI.

d.

Il s’agit d’un MAU (Multistation Access Unit) ou concentrateur Token Ring 8 ports ancienne génération (connecteurs hermaphrodites et non RJ45). Ce composant agit au niveau 1 du modèle OSI.

e.

Il s’agit d’un répéteur 10baseT/10baseFL permettant de régénérer un signal à 10 Mbps (codage Manchester) de la paire torsadée vers de la fibre (et vice-versa). Ce composant est défini au niveau 1 OSI.

f.

C’est un catalyst 2950 CISCO disposant de 24 ports fastEthernet. Il s’agit d’un commutateur niveau 2 OSI. Il est administrable...

Corrigé 4.7 Composants d’interconnexion et identifiants

a.

Il s’agit d’un pont Ethernet (niveau 2). Il est donc capable de comprendre un signal (4) ainsi que les adresses MAC (3) pour assurer un filtrage de niveau 2.

b.

Il s’agit d’un hub ou concentrateur Ethernet (actif). Il agit comme répéteur (coaxial fin vers paire torsadée). Il est donc seulement capable d’interpréter un signal (4) mais pas au-delà (ni adresse MAC, ni au-delà).

c.

Il s’agit d’un routeur CISCO 1721 qui agit donc au niveau 3. Ces routeurs sont capables de prendre en charge un premier niveau de filtrage de niveau 3 au moyen de liste de contrôle d’accès (Access List). Ce routeur peut donc comprendre les quatre types d’identifiants proposés (réponses 1, 2, 3 et 4).

d.

Il s’agit d’un répéteur Ethernet (Transceiver 10baseT, 10base5). Il ne fonctionne qu’au niveau 1, il ne comprend pas la signification des trames, même s’il est en mesure de faire du codage/décodage Manchester à la volée. Seule la réponse (4) est correcte ici.

e.

Il s’agit d’un MAU (Multistation Access Unit) ou concentrateur Token Ring. Il s’agit ici d’un composant de niveau 1 ; ainsi, seule la réponse (4) est valide.

f.

Il s’agit d’un commutateur CISCO (catalyst, 2950 24 ports Fast Ethernet)...

Corrigé 4.8 Autoapprentissage d’un pont

1.

La première étape consiste à identifier les deux domaines de bande passante qui sont ici des domaines de collisions. Pour cela, il faut clairement préciser le niveau de fonctionnement (au sens du modèle OSI) de chaque périphérique ; dans l’ordre, il y a deux hubs, un répéteur, un pont et un autre hub.

Souvenez-vous qu’un domaine de collisions englobe des composants de niveau 1 et s’arrête à un composant de niveau 2 (pont ou commutateur).

images/04TP62.png

Ensuite, pour chaque trame arrivant, le pont va lire l’adresse de destination pour savoir si la trame a besoin d’être répétée de l’autre côté. Le pont va en profiter pour apprendre l’adresse MAC de la source, lue dans la trame. Il pourra ainsi associer cette adresse MAC à une origine (à gauche ou à droite) sur notre schéma. Notez que le pont laisse passer les diffusions ainsi que les trames multicast (adressées à un groupe d’ordinateurs).

Le tableau ci-dessous est ainsi obtenu :

Itération

Source

Destination

La trame traverse-t-elle le pont (O ou N) ?

Quelle adresse est apprise ?

Explications

1

A

FF.FF.FF.FF.FF.FF

O

L’adresse Source de la trame, soit A.

Toutes les diffusions passent le pont. Il peut s’agir par exemple d’une requête ARP ou d’un client DHCP.

2

B

A

N

B

La trame inonde le domaine de collisions C1.

3

F

G

O

F

La trame inonde C2, puis est répétée sur C1 : en effet, le pont ne sait pas où est G.

4

G

FF.FF.FF.FF.FF.FF

O

G

Le domaine de diffusion est constitué de C1 + C2.

5

G

F

N

Le pont sait déjà que G est à droite...

Corrigé 4.9 Algorithme du Spanning Tree

images/N04-TP03.png

Pour influencer le calcul du Spanning Tree, nous proposons de modifier la priorité des commutateurs cœurs de réseau. Nous remplaçons donc la valeur 0x8000 par 0x4000 : la plus petite valeur étant la plus prioritaire.

Cela permet de garantir que le Pont Racine (Root Bridge) sera obligatoirement l’un des deux cœurs.

Identifions également les coûts des liaisons entre commutateurs. Nous disposons de débits à 2x10 Gbps et des débits à 1 Gbps.

Les coûts correspondants sont :

2x10 Gbps vaut 1 000.

1 Gbps vaut 20 000.

De plus, nous proposons d’identifier chaque commutateur par une lettre et un chiffre.

Nous obtenons ainsi le schéma suivant :

images/N04-TP04.png

La première étape consiste en l’identification du Root Bridge de l’infrastructure.

Il s’agit du commutateur qui dispose du couple (Priorité,@Mac) le plus petit.

Il s’agit donc du commutateur A2 (dès lors que la priorité a été modifiée).

Nous identifions ensuite le Root Port de chaque commutateur : il s’agit du port à partir duquel le chemin au Root Bridge est le moins coûteux.

Il faut effectuer cette opération pour chacun des commutateurs de l’infrastructure :

images/N04-TP05.png

Les ports désignés (Designated Port ou DP) sont ensuite déterminés. Il s’agit d’identifier...

Corrigé 4.10 Protocoles de routage

Routage

ligne

Statique

Dynamique

2

 

Protocoles extérieurs

Protocoles intérieurs

3

 

Vecteur de distance

État de liaison

4

BGP

RIP

OSPF

NLSP

5

Corrigé 4.11 Calcul d’une convergence RIPv2 - exercice 1

images/N04-TP01.png

Initialement, les routeurs ont connaissance des réseaux auxquels ils sont immédiatement connectés. Ce qui donne :

Routeur R1

Réseau

Interface

Saut

 

172.16.0.0/16

Fa0/0

0

 

192.168.2.0/24

Fa0/1

0

Routeur R2

Réseau

Interface

Saut

 

192.168.2.0/24

Fa0/0

0

 

172.20.0.0/16

Fa0/1

0

 

192.168.1.0/24

Fa0/2

0

 

192.168.3.0/24

Fa0/3

0

Routeur R3

Réseau

Interface

Saut

 

172.21.0.0/16

Fa0/0

0

 

192.168.3.0/24

Fa0/1

0

Routeur R4

Réseau

Interface

Saut

 

192.168.1.0/24

Fa0/0

0

 

172.32.0.0/16

Fa0/1

0

Lorsque R1 va diffuser sa table de routage à son voisin R2, R2 va apprendre l’existence du réseau 172.16.0.0/16 par son interface Fa0/0 :

Routeur R2

Réseau

Interface

Saut

 

192.168.2.0/24

Fa0/0

0

 

172.20.0.0/16

Fa0/1

0

 

192.168.1.0/24

Fa0/2

0

 

192.168.3.0/24

Fa0/3

0

 

172.16.0.0/16

Fa0/0

1

Puis par mise à jour déclenchée, R3 et R4 vont apprendre ce même réseau :

Routeur R3

Réseau

Interface

Saut

 

172.21.0.0/16

Fa0/0

0

 

192.168.3.0/24

Fa0/1

0

 

172.16.0.0/16

Fa0/1

2

Routeur R4

Réseau

Interface

Saut

 

192.168.1.0/24

Fa0/0

0

 

172.32.0.0/16

Fa0/1

0

 

172.16.0.0/16

Fa0/0

2

De même, R3 va envoyer sa table de routage à son voisin R2, qui va apprendre que le réseau 172.21.0.0/16 est accessible en un saut par son interface Fa0/3.

R2 va à son tour propager l’ensemble de sa table de routage, et donc l’information concernant l’existence du réseau 172.21.0.0/16 à ses voisins R1 et R4 en deux sauts.

R4 va apprendre à R2 l’existence du réseau 172.32.0.0/16. R2 va ensuite propager cette information aux deux routeurs adjacents R1 et R3.

Une fois la convergence complète de RIP réalisée, les informations ci-dessous sont finalement obtenues :

Routeur R1

Réseau

Interface

Saut

 

172.16.0.0/16

Fa0/0

0

 

192.168.2.0/24

Fa0/1

0

 

172.21.0.0/16

Fa0/1

2

 

172.32.0.0/16

Fa0/1

2

 

192.168.3.0/24

Fa0/1

1

 

192.168.1.0/24

Fa0/1

1

 

172.20.0.0/16

Fa0/1

1

Routeur R2

Réseau

Interface

Saut

 

192.168.2.0/24

Fa0/0

0

 

172.20.0.0/16

Fa0/1

0

 

192.168.1.0/24

Fa0/2

0

 

192.168.3.0/24

Fa0/3

0

 

172.16.0.0/16

Fa0/0...

Corrigé 4.12 Calcul d’une convergence RIPv2 - exercice 2

images/N04-TP02.png

Routeur R1

Réseau

Interface

Saut

 

10.1.0.0/16

Fa0/0

0

 

10.2.0.0/16

Fa0/1

0

 

10.3.0.0/16

Fa0/2

0

 

10.5.0.0/16

Fa0/0

1

 

10.7.0.0/16

Fa0/0

2

 

10.6.0.0/16

Fa0/0

2

 

10.8.0.0/16

Fa0/0

2

 

10.4.0.0/16

Fa0/2

1

Routeur R2

Réseau

Interface

Saut

 

10.1.0.0/16

Fa0/0

0

 

10.5.0.0/16

Fa0/1

0

 

10.7.0.0/16

Fa0/1

1

 

10.6.0.0/16

Fa0/1

1

 

10.8.0.0/16

Fa0/1

1

 

10.2.0.0/16

Fa0/0

1

 

10.3.0.0/16

Fa0/0

1

 

10.4.0.0/16

Fa0/0

2

Routeur R3

Réseau

Interface

Saut

 

10.3.0.0/16

Fa0/0

0

 

10.4.0.0/16

Fa0/1

0

 

10.2.0.0/16

Fa0/0

1

 

10.1.0.0/16

Fa0/0

1

 

10.5.0.0/16

Fa0/0

2

 

10.6.0.0/16

Fa0/0

3

 

10.8.0.0/16

Fa0/0

3

 

10.7.0.0/16

Fa0/0

3

Routeur R4

Réseau

Interface

Saut

 

10.5.0.0/16

Fa0/0

0

 

10.7.0.0/16

Fa0/1

0

 

10.6.0.0/16

Fa0/0

1

 

10.8.0.0/16

Fa0/0

1

 

10.1.0.0/16

Fa0/0

1

 

10.2.0.0/16

Fa0/0

2

 

10.3.0.0/16

Fa0/0

2

 

10.4.0.0/16

Fa0/0

3

Routeur R5

Réseau

Interface

Saut

 

10.5.0.0/16

Fa0/0

0

 

10.6.0.0/16

Fa0/1

0

 

10.8.0.0/16

Fa0/2

0

 

10.7.0.0/16

Fa0/0

1

 

10.1.0.0/16

Fa0/0

1

 

10.2.0.0/16

Fa0/0

2

 

10.3.0.0/16

Fa0/0

2

 

10.4.0.0/16

Fa0/0

3

Corrigé 4.13 Installation de Packet Tracer

 

Inscription sur le site Networking Academy

1.

Accédez au site netacad.com :

https://www.netacad.com/fr/courses/packet-tracer

images/04TP01V7.png

2.

En faisant défiler verticalement, vous allez pouvoir accéder à quelques cours et en profiter pour créer un compte. Cela vous permettra ensuite de télécharger gratuitement le logiciel Packet Tracer.

images/04TP02V7.png

3.

Sélectionnez un cours. Une fenêtre de redirection doit s’ouvrir.

Il se peut que le navigateur bloque cette redirection.

Observez en haut à droite le blocage et déverrouillez l’accès :

images/04TP03V7.png

4.

Le cours s’affiche.

Cliquez sur Démarrer.

images/04TP04V7.png

5.

Une fois que vous avez choisi la langue, un écran s’affiche pour vous inviter à vous inscrire :

images/04TP05V7.png

6.

Choisissez un type de compte ou cliquez sur Sign up.On va vous demander de choisir le pays, votre année de naissance et votre mois de naissance. 

images/04TP06V7.png

7.

Précisez vos identifiants, email et mot de passe associé.

images/04TP07V7.png

8.

Acceptez les conditions générales.

Vous avez alors accès au cours.

Téléchargement de Packet Tracer

1.

Parcourez le cours pour vous familiariser au fonctionnement de Packet Tracer.

images/04TP08V7.png

2.

En parcourant le cours, on obtient l’URL suivante : https://skillsforall.com/resources/lab-downloads

Déroulez la page, pour parvenir au lien de téléchargement de Packet Tracer :

images/04TP09V7.png

3.

Téléchargez le package d’installation (222 Mo) pour Windows :

images/04TP10V7.png

Installation de Packet Tracer

1.

Sur votre poste de travail Windows 10, démarrez l’exécution du programme téléchargé précédemment.

Clic droit, Exécuter en tant qu’administrateur :

images/04TP11V7.png

2.

Après avoir autorisé l’exécution du programme certifié par Cisco Systems, sélectionnez I accept the agreement puis cliquez sur Next :

images/04TP12V7.png

3.

Laissez le répertoire par défaut et cliquez sur Next :

images/04TP13V7.png

4.

Validez...

Corrigé 4.14 Configuration 1 - sans VLAN

Nous allons créer une configuration basique comprenant deux PC et un commutateur sans configuration. Les adresses IP sont définies sur chaque ordinateur. Il n’y a pas de passerelle (un seul sous-réseau).

 

Ajout du commutateur

1.

Dans le coin inférieur gauche, déplacez votre souris pour sélectionner l’icône correspondant à la catégorie [Network devices].

images/04TP24V7.png

2.

Choisissez ensuite en dessous, l’item [Switches].

La liste des périphériques change automatiquement :

images/04TP25V7.png

3.

Choisissez alors le commutateur 2950-24 puis cliquez sur l’écran central pour coller le commutateur :

images/04TP26V7.png

 

Ajout des postes de travail

1.

Sélectionnez en bas à gauche [End devices], vérifiez que [End devices] est également sélectionné en dessous, puis choisissez PC comme poste de travail, et cliquez une fois sur la zone de dessin.

images/04TP27V7.png

2.

Sélectionnez à nouveau PC puis cliquez une nouvelle fois sur une zone vierge de l’écran. Vous devriez avoir la représentation ci-dessous :

images/04TP28V7.png

 

Création des connexions réseau

1.

Cliquez sur [Connections], comme indiqué ci-après, cliquez sur la première icône « qui choisit automatiquement le type de connexion »,

images/tp04rp36_1.png

puis effectuez un premier clic gauche sur le premier PC, passez la souris...

Corrigé 4.15 Configuration 2 - VLAN simples

Nous allons à présent ajouter des VLAN par port, en reprenant la configuration précédente, afin de vérifier l’étanchéité des VLAN (absence de communication entre les postes alors qu’ils sont connectés sur le même commutateur).

 

Identification des interfaces utilisées

1.

Cliquez sur le commutateur et accédez à l’onglet CLI (Command Line Interface).

images/04TP37V7.png

2.

Appuyez sur [Entrée], le prompt Switch> s’affiche.

images/04TP38V7.png

3.

Activez le mode "Administrateur" (mode enable), en tapant enable ou en.

 

Tapez ensuite la commande show interfaces status ou sh int status.

images/tp04-r-p36-3.png

4.

Pour arrêter le défilement, appuyer sur la touche q ou [Entrée] pour faire défiler ligne par ligne.

Identifiez les interfaces qui ont le statut "connected" :

 

Fa0/1, Fa0/2

 

Identification des adresses MAC connnectées

1.

Nous souhaiterions savoir quel poste est connecté sur quelle interface. Pour cela, nous allons regarder dans la table d’adresses MAC quelles adresses MAC apparaissent sur quels ports.

 

Tapez la commande show mac address-table ou sh mac add.

 

Si la table est vide, c’est que le dernier ping date un peu et que le cache a été vidé.

Si c’est le cas, relancez un ping avant d’afficher à nouveau le contenu de la table.

images/04TP40V7.png

 

On peut ainsi vérifier quelle adresse MAC est connectée sur quel port du commutateur.

2.

La commande ipconfig /all nous précise l’adresse MAC associée au PC :

images/04TP41V7.png

3.

On en déduit que PC0 est sur Fa0/1 et PC1 sur Fa0/2.

 

Activation des VLAN

1.

Nous allons définir le VLAN 101 sur le port de connexion de PC0 (mais pas sur le port...

Corrigé 4.16 Configuration 3 - routeur et commutateurs dédiés pour chaque sous-réseau

Nous allons recréer un environnement avec un routeur et deux commutateurs.

Chaque ordinateur sera connecté à son commutateur. Les commutateurs seront alors connectés au routeur sur une interface de niveau 3 (faisant office de passerelle pour les équipements connectés au commutateur). Les postes définissent comme passerelle l’interface de niveau 3 sur laquelle le commutateur est branché.

 

Ajout des composants

1.

Redémarrez sur un nouvel environnement : menu File - New.

2.

Ajoutez les composants ci-dessous :

- Routeur : [Routers] - 1941

- Commutateurs : [Switches] - 2950-24 x 2

- Ordinateurs : [End devices] - Generic x 4

 

Vous devriez obtenir le schéma ci-dessous :

images/04TP46V7.png

3.

Définissez les connexions entre les équipements, dans l’ordre suivant :

PC0 -> Switch 0

PC1 -> Switch 0

PC2 -> Switch 1

PC3 -> Switch 1

Switch 0 -> Router0

Switch 1 -> Router0

images/04TP47V7.png

 

Définition des interfaces de niveau 3 sur le routeur

1.

Connectez-vous au routeur et choisissez l’onglet CLI :

2.

Répondez "no" à la question posée "Would you like to enter the initial configuration dialog ?" :

images/04TP48V7.png

3.

Définissez le nom du routeur à "routeur1" :

enable

conf t

hostname routeur1

exit

4.

Observez le changement du prompt.

5.

Affichez un résumé des interfaces actuellement définies :

show ip interface brief

ou

sh ip int brief

images/04TP49V7.png

 

Vérifiez qu’aucune...

Corrigé 4.17 Configuration 4 - commutateur Multilayer et liaisons trunk avec les commutateurs configurés avec des VLAN

Nous allons enrichir une nouvelle fois la configuration, en proposant un cœur de réseau Multilayer avec des interfaces VLAN. Les deux commutateurs sont, quant à eux, connectés en niveau 2 au cœur de réseau au moyen d’une liaison de type trunk. Les VLAN par port sont alors définis sur les commutateurs, qui sont ainsi capables de gérer des équipements connectés sur des VLAN spécifiques. Les postes de travail se voient alors configurés avec les passerelles des sous-réseaux qui sont finalement les IP des interfaces VLAN définies sur le cœur de réseau.

On va placer deux PC sur chaque commutateur.

Les PC dont le nom se termine par un nombre pair seront placés dans le VLAN pair (102).

Les PC dont le nom se termine par un nombre impair seront placés dans le VLAN impair (101).

Par exemple :

PC4 et PC6 seront dans le VLAN 102.

PC5 et PC7 seront dans le VLAN 101.

Le sous-réseau associé au VLAN 101 sera défini par 10.1/16 avec une adresse de passerelle 10.1.255.254.

Le sous-réseau associé au VLAN 102 sera défini par 10.2/16 avec une adresse de passerelle 10.2.255.254.

 

Ajout des composants

1.

Ouvrez un nouveau schéma : menu File - New.

2.

Ajoutez les composants ci-dessous :

- Switch Multilayer : [Network devices] [Switches] - 3560 24PS

- Commutateurs : [Network devices] [Switches] - 2950-24 x 2

- Ordinateurs : [End devices] - PC x 4

3.

Configurez les connexions.

Vous devriez obtenir quelque chose de semblable à ceci :

images/04TP53V7.png

 

Configuration des interfaces VLAN du commutateur Multilayer

 

Nous allons définir des interfaces VLAN ; c’est-à-dire que plutôt que de configurer une interface physique avec une adresse IP, nous allons associer cette adresse IP à une interface virtuelle. Cette interface virtuelle identifiera la passerelle par défaut d’un sous-réseau, où un sous-réseau correspond à un VLAN. Les périphériques disposant d’une adresse IP sur le sous-réseau, référenceront comme adresse de passerelle par défaut, l’adresse IP de l’interface VLAN.

1.

Affichez la liste des interfaces...

Corrigé 4.18 Configuration 6 - Routage dynamique (base)

Dans cet exercice, nous allons créer un environnement avec plusieurs routeurs, commutateurs et des postes de travail. Nous allons ensuite activer plusieurs protocoles de routage dynamique pour permettre aux ordinateurs de communiquer (après synchronisation des tables de routage des routeurs).

Nous allons respectivement configurer RIPv2, EIGRP et OSPF.

Le schéma ci-dessous représente l’ensemble sans les commutateurs de niveau 2 (non configurés). 

images/04TP06N54.png

 

Ajout des composants

1.

Ajoutez 4 commutateurs 3560-24PS (Multilayer) qui vont être nos routeurs.

2.

Ajoutez 4 commutateurs 2960-24TT qui serviront à connecter les postes de travail.

3.

Ajoutez 4 postes de travail génériques.

4.

Connectez tout d’abord chaque PC à son commutateur de niveau 2.

5.

Connectez ensuite chaque 2960 au 3560.

6.

Le second 3560 (Multilayer switch1), qu’on appellera R2, sera connecté à R1 (préalablement Multilayer switch0), à R3 (Multilayer Switch2) et à R4 (Multilayer Switch3).

images/04TP63V7.png

7.

Renommez (hostname) chacun des équipements utilisés :

2960 Switch0 devient SW1

2960 Switch1 devient SW2

2960 Switch2 devient SW3

2960 Switch3 devient SW4

3560 Multilayer Switch0 devient R1

3560 Multilayer Switch1 devient R2

3560 Multilayer Switch2 devient R3

3560 Multilayer Switch3 devient R4

Remarque : procédez de même en mode graphique pour que le nom soit bien affiché.

8.

Modifiez l’affichage : menu Options - Preferences, décochez Show Device Model Labels et cochez Always Show Port Labels in Logical Workspace. Cela va permettre d’afficher les interfaces actives, ce qui est plus facile pour procéder à leur configuration.

 

Après renommage et affichage des ports, voici ce que l’on obtient :

images/04TP64V7.png

 

Configuration des interfaces de niveau 3 des routeurs

 

Voici une représentation des équipements faisant apparaître les adresses IP :

images/04TP06N55.png

 

R1 : Fa0/1, IP=10.1.0.254/16

R1 : Fa0/2, IP=10.2.0.253/16

R2 : Fa0/1, IP=10.2.0.254/16

R2 : Fa0/2, IP=10.3.0.254/16

R2 : Fa0/3, IP=10.4.0.253/16

R2 : Fa0/4, IP=10.5.0.254/16

R3 : Fa0/1, IP=10.7.0.253/16

R3 : Fa0/2, IP=10.5.0.253/16...

Corrigé 4.19 Configuration 6 - Routage RIPv2

 

Activation du protocole de routage dynamique RIPv2

 

Continuez avec la configuration précédemment réalisée.

 

Nous allons activer sur les 4 routeurs le protocole RIPv2 pour les réseaux 10.0.0.0.

images/04TP06N62.png

1.

Sur chacun des 4 routeurs, activez RIPv2 pour le réseau 10.0.0.0 :

enable

conf t

router rip

version 2

network 10.0.0.0

exit

exit

2.

Après quelques instants, les tables de routage sont échangées entre routeurs.

Vous devriez obtenir ceci pour R1 :

images/04TP69V7.png

 

R2 :

images/04TP70V7.png

 

R3 :

images/04TP71V7.png

 

R4 :

images/04TP72V7.png

 

Enregistrement de la configuration

1.

Enregistrez la configuration de chaque switch/routeur au moyen de la commande "write mem".

2.

Sauvegardez la configuration en Configuration6-Routage-RIPV2.

3.

Une fois les tables de routage synchronisées, tous les postes de travail peuvent se joindre mutuellement. Le test de connectivité (ping) permet de s’assurer que tous les PC sont joignables à partir d’un PC spécifique.

Corrigé 4.20 Configuration 6 - Routage EIGRP

 

Activation du protocole de routagedynamique EIGRP

 

Nous allons voir comment activer le protocole de routage EIGRP de manière simple, en définissant un AS 100 (Autonomous System).

1.

Repartez de "Configuration6-Routage-base".

 

Si besoin, vous pouvez annuler la configuration RIP sur chacun des 4 routeurs, au moyen des commandes ci-dessous :

enable

conf t

no router rip

exit

exit

images/04TP06N67.png

2.

Sur chacun des 4 routeurs, activez EIGRP pour le réseau 10.0.0.0 sur l’AS 100 :

enable

conf t

router eigrp 100

network 10.0.0.0

exit

exit

 

Après quelques instants, les tables de routage sont échangées entre routeurs.

3.

Vous devriez obtenir ceci :

 

R1 :

images/04TP73V7.png

R2 :

images/04TP74V7.png

R3 :

images/04TP75V7.png

 

R4 :

images/04TP76V7.png

 

Enregistrement de la configuration

1.

Enregistrez les configurations des équipements réseau avec write mem sur chacun d’entre eux.

2.

Sauvegardez la configuration en Configuration6-Routage-EIGRP.

Corrigé 4.21 Configuration 6 - Routage OSPF

 

Activation du protocole de routage dynamique OSPF

1.

Repartez de "Configuration6-Routage-base".

images/04TP06N72.png

 

Nous allons configurer l’utilisation du protocole de routage OSPF sur l’aire 0 en définissant des id de processus à 1. Nous allons utiliser la notation des masques inversés. Ainsi, pour définir le sous-réseau 10.1/16 ou 10.1.0.0/255.255.0.0, on écrira avec OSPF 10.1.0.0/0.0.255.255.

Pour OSPF, nous allons spécifiquement définir les sous-réseaux sur lesquels on souhaite faire opérer OSPF. Dans notre exercice, nous allons gérer tous les réseaux. On aurait cependant pu faire un mix avec d’autres protocoles de routage.

2.

Utilisez les commandes ci-dessous pour configurer R1.

enable

conf t

router ospf 1

network 10.1.0.0 0.0.255.255 area 0

network 10.2.0.0 0.0.255.255 area 0

exit

exit

3.

Utilisez les commandes ci-dessous pour configurer R2.

enable

conf t

router ospf 1

network 10.2.0.0 0.0.255.255 area 0

network 10.3.0.0 0.0.255.255 area 0

network 10.4.0.0 0.0.255.255 area 0

network 10.5.0.0 0.0.255.255 area 0

exit

exit

4.

Utilisez les commandes ci-dessous pour configurer R3.

enable

conf t

router ospf 1

network 10.5.0.0 0.0.255.255 area 0

network 10.7.0.0 0.0.255.255 area 0

exit

exit

5.

Utilisez les commandes ci-dessous pour configurer R4.

enable

conf t

router ospf 1

network 10.4.0.0 0.0.255.255 area 0

network...